lighttpd: add simple startup script
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 17:17:48 +0000 (19:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 17:17:48 +0000 (19:17 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lighttpd/S50lighttpd [new file with mode: 0644]
package/lighttpd/lighttpd.mk

diff --git a/package/lighttpd/S50lighttpd b/package/lighttpd/S50lighttpd
new file mode 100644 (file)
index 0000000..752402c
--- /dev/null
@@ -0,0 +1,37 @@
+#!/bin/sh
+#
+# Starts lighttpd.
+#
+
+start() {
+       echo -n "Starting lighttpd: "
+       start-stop-daemon -S -q -p /var/run/lighttpd.pid --exec /usr/sbin/lighttpd -- -f /etc/lighttpd/lighttpd.conf
+       echo "OK"
+}
+stop() {
+       echo -n "Stopping lighttpd: "
+       start-stop-daemon -K -q -p /var/run/lighttpd.pid
+       echo "OK"
+}
+restart() {
+       stop
+       start
+}
+
+case "$1" in
+  start)
+       start
+       ;;
+  stop)
+       stop
+       ;;
+  restart|reload)
+       restart
+       ;;
+  *)
+       echo "Usage: $0 {start|stop|restart}"
+       exit 1
+esac
+
+exit $?
+
index 48f733a3de2ed90b2cb64cdbe4f99a3be7b086c7..9f554cbc35681bd125fe04e0f587c5265166ee6c 100644 (file)
@@ -87,6 +87,14 @@ endef
 
 LIGHTTPD_POST_INSTALL_TARGET_HOOKS += LIGHTTPD_INSTALL_CONFIG
 
+define LIGHTTPD_INSTALL_INIT_SCRIPT
+       [ -f $(TARGET_DIR)/etc/init.d/S50lighttpd ] || \
+               $(INSTALL) -D -m 755 package/lighttpd/S50lighttpd \
+                       $(TARGET_DIR)/etc/init.d/S50lighttpd
+endef
+
+LIGHTTPD_POST_INSTALL_TARGET_HOOKS += LIGHTTPD_INSTALL_INIT_SCRIPT
+
 define LIGHTTPD_UNINSTALL_TARGET_CMDS
        $(RM) $(TARGET_DIR)/usr/sbin/lighttpd
        $(RM) $(TARGET_DIR)/usr/sbin/lighttpd-angel