package/wlroots: bump to version 0.14.1
authorAdrian Perez de Castro <aperez@igalia.com>
Wed, 11 Aug 2021 11:11:57 +0000 (14:11 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 13 Aug 2021 13:17:42 +0000 (15:17 +0200)
Update to version 0.14.1, and adapt to upstream changes:

- seatd/libseat is now used unconditionally, the logind/elogind build
  options have been removed (which can be used through seatd, no
  functionality is lost).
- Now wlroots includes a software-based renderer (which uses pixman),
  and the OpenGL ES one is optional. For now it is left always enabled
  (as it was before) but this could be changed in the future.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wlroots/Config.in
package/wlroots/wlroots.hash
package/wlroots/wlroots.mk

index 41f8986772c25fa3a93559807ed47d1dcf10421b..8d485992f50576fa9050dad660a3973a0ef59176 100644 (file)
@@ -20,6 +20,7 @@ config BR2_PACKAGE_WLROOTS
        select BR2_PACKAGE_LIBINPUT
        select BR2_PACKAGE_LIBXKBCOMMON
        select BR2_PACKAGE_PIXMAN
+       select BR2_PACKAGE_SEATD
        select BR2_PACKAGE_WAYLAND
        select BR2_PACKAGE_WAYLAND_PROTOCOLS
        help
index 024ea93caee8f5bcb9caa62f3090d9d1ffdf40cf..fdebe1ef68465b582423b3732a089de340e9eacf 100644 (file)
@@ -1,5 +1,5 @@
-# Generated locally, after checking https://github.com/swaywm/wlroots/releases/download/0.13.0/wlroots-0.13.0.tar.gz.sig
-sha256  f6bea37fd4a6f5e5f552b83d61adae8c73e64b0bcb9ae0ab464ebcd9309d3cf3  wlroots-0.13.0.tar.gz
+# Generated locally, after checking https://github.com/swaywm/wlroots/releases/download/0.14.1/wlroots-0.14.1.tar.gz.sig
+sha256  448a83d579ac280357c8a4e902b9477bacbab81cc4d9c140e443642d458869db  wlroots-0.14.1.tar.gz
 
 # Hashes for license files:
 sha256  ffd3737a478b83a8b51b42757d3bf909ef36694508355879722e11fc1fa6736b  LICENSE
index 0696d037df27cc7b5fe12e96ad4915831dd8daaa..89d50241762b5eb400b8ee1585eccc2c6746fa19 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-WLROOTS_VERSION = 0.13.0
+WLROOTS_VERSION = 0.14.1
 WLROOTS_SITE = https://github.com/swaywm/wlroots/releases/download/$(WLROOTS_VERSION)
 WLROOTS_LICENSE = MIT
 WLROOTS_LICENSE_FILES = LICENSE
@@ -18,11 +18,12 @@ WLROOTS_DEPENDENCIES = \
        libegl \
        libgles \
        pixman \
+       seatd \
        udev \
        wayland \
        wayland-protocols
 
-WLROOTS_CONF_OPTS = -Dexamples=false -Dxcb-errors=disabled
+WLROOTS_CONF_OPTS = -Dexamples=false -Dxcb-errors=disabled -Drenderers=gles2
 
 ifeq ($(BR2_PACKAGE_FFMPEG),y)
 WLROOTS_DEPENDENCIES += ffmpeg
@@ -32,13 +33,6 @@ ifeq ($(BR2_PACKAGE_LIBPNG),y)
 WLROOTS_DEPENDENCIES += libpng
 endif
 
-ifeq ($(BR2_PACKAGE_SYSTEMD_LOGIND),y)
-WLROOTS_CONF_OPTS += -Dlogind=enabled -Dlogind-provider=systemd
-WLROOTS_DEPENDENCIES += systemd
-else
-WLROOTS_CONF_OPTS += -Dlogind=disabled
-endif
-
 ifeq ($(BR2_PACKAGE_WLROOTS_X11),y)
 WLROOTS_CONF_OPTS += -Dx11-backend=enabled -Dxwayland=enabled
 WLROOTS_DEPENDENCIES += libxcb xcb-util-wm xcb-util-renderutil xlib_libX11
@@ -46,11 +40,4 @@ else
 WLROOTS_CONF_OPTS += -Dx11-backend=disabled -Dxwayland=disabled
 endif
 
-ifeq ($(BR2_PACKAGE_SEATD),y)
-WLROOTS_CONF_OPTS += -Dlibseat=enabled
-WLROOTS_DEPENDENCIES += seatd
-else
-WLROOTS_CONF_OPTS += -Dlibseat=disabled
-endif
-
 $(eval $(meson-package))