projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
46c6443
)
gd: use pkg-config to figure out png linker flags
author
Peter Korsgaard
<peter@korsgaard.com>
Tue, 25 Nov 2014 14:54:46 +0000
(15:54 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Tue, 25 Nov 2014 14:57:11 +0000
(15:57 +0100)
So gdlib-config --libs returns the full dependency chain (-lpng16 -lz -m)
when linking statically.
Fixes http://autobuild.buildroot.net/results/dac/
dac3eb950c7c27b2f09f001f9db9936f897721f9
/
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gd/gd.mk
patch
|
blob
|
history
diff --git
a/package/gd/gd.mk
b/package/gd/gd.mk
index d0fd5720a00aef08de7355fa2796514b0cb819e6..16134644460187982e45d20b7e2b7f74dba35fb6 100644
(file)
--- a/
package/gd/gd.mk
+++ b/
package/gd/gd.mk
@@
-40,7
+40,7
@@
endif
ifeq ($(BR2_PACKAGE_LIBPNG),y)
GD_DEPENDENCIES += libpng
-GD_CONF_OPTS += --with-png
=$(STAGING_DIR)/usr
+GD_CONF_OPTS += --with-png
else
GD_CONF_OPTS += --without-png
endif