webkitgtk24: fix gstreamer dependency
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Mar 2016 21:43:15 +0000 (22:43 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Mar 2016 21:43:15 +0000 (22:43 +0100)
Fixes:
http://autobuild.buildroot.net/results/a28/a280f23cc29f77ab440edbda05b4e58d6f4856e7/

The .mk file was checking for gst1-plugins-base but then adding
gst1-plugins-good to dependencies.

According to Source/autotools/FindDependencies.m4, the video and web audio
options need the .pc files provided by gst1-plugins-base, so use that.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/webkitgtk24/webkitgtk24.mk

index 0dc47748d0a9c97628ace7bbd99a778236dfce48..d8e41b940819d06d7cb805749c703c639b54cc91 100644 (file)
@@ -46,7 +46,7 @@ ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
 WEBKITGTK24_CONF_OPTS += \
        --enable-video \
        --enable-web-audio
-WEBKITGTK24_DEPENDENCIES += gst1-plugins-good
+WEBKITGTK24_DEPENDENCIES += gst1-plugins-base
 else
 WEBKITGTK24_CONF_OPTS += \
        --disable-video \