toolchain: fix multilib symlink for external toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Dec 2010 12:49:37 +0000 (13:49 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 21 Dec 2010 12:57:11 +0000 (13:57 +0100)
ARCH_SUBDIR is a shell variable, so it should be referenced with
$${ARCH_SUBDIR}. Without this, no symbolic link is created, and the
external toolchain fails to work if the non-default multilib variant
is used.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk

index 9b37f3f6c56fa0d85fbee17cd2f3f493e3e80d5d..eb9d7421d4bcb34c8e43b01b5ded795ac977bfd1 100644 (file)
@@ -96,7 +96,7 @@ copy_toolchain_sysroot = \
                if [ ! -d $${ARCH_SYSROOT_DIR}/usr/include ] ; then \
                        cp -a $${SYSROOT_DIR}/usr/include $(STAGING_DIR)/usr ; \
                fi ; \
-               ln -s . $(STAGING_DIR)/$(ARCH_SUBDIR) ; \
+               ln -s . $(STAGING_DIR)/$${ARCH_SUBDIR} ; \
        fi ; \
        find $(STAGING_DIR) -type d | xargs chmod 755