package/kmsxx: detect failure at install-staging
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 5 Aug 2016 18:05:00 +0000 (20:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 5 Aug 2016 18:59:42 +0000 (20:59 +0200)
Currently, the staging-install commands do not detect failures to
install the libs.

That's because we use ';' to separate the commands, so we only get the
result of the last one.

Fix that by using multi-line commands, so they each are called on their
own and make would catch the failures.

Partially fixes (only detects the real failure):
    http://autobuild.buildroot.org/results/82c/82cfb7451f933b222abe30b5d35d23e409a4af79
    and a few others.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Maxime Ripard <maxime.ripard@free-electrons.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kmsxx/kmsxx.mk

index d49ec8fe7d25c89e8d304cea0d7e99aec87a1889..84c860c4a190ef7dab19e72bb3ecb5d60ef2640a 100644 (file)
@@ -39,8 +39,8 @@ endef
 define KMSXX_INSTALL_STAGING_CMDS
        $(foreach l,$(KMSXX_LIBS),\
                $(INSTALL) -D -m 0755 $(@D)/lib/lib$(l).so \
-                       $(STAGING_DIR)/usr/lib/lib$(l).so ; \
-               mkdir -p $(STAGING_DIR)/usr/include/$(l) ; \
+                       $(STAGING_DIR)/usr/lib/lib$(l).so
+               mkdir -p $(STAGING_DIR)/usr/include/$(l)
                cp -dpfr $(@D)/$(l)/inc/$(l)/* $(STAGING_DIR)/usr/include/$(l)/
        )
 endef