package/tio: new package
authorSergio Prado <sergio.prado@e-labworks.com>
Sun, 22 Dec 2019 22:12:03 +0000 (19:12 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 24 Dec 2019 13:11:43 +0000 (14:11 +0100)
"tio" is a simple TTY terminal application which features a
straightforward commandline interface to easily connect to
TTY devices for basic input/output.

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
[Thomas:
 - license is GPL-2.0+ (noticed by Baruch)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/tio/Config.in [new file with mode: 0644]
package/tio/tio.hash [new file with mode: 0644]
package/tio/tio.mk [new file with mode: 0644]

index c86fd5931fa09ddd4d60ee4be97582b0ced7d702..284fc7c57e2a2f9c1f3b45a6c83be81d88a22961 100644 (file)
@@ -2216,6 +2216,7 @@ F:        package/libgdiplus/
 F:     package/pimd/
 F:     package/snort/
 F:     package/stella/
+F:     package/tio/
 F:     package/traceroute/
 F:     package/tunctl/
 F:     package/ubus/
index df4265ead3fe479e4c5bf02114b467e225640680..efe90dfc09702a5f7073d8fe4f68ef32624986ca 100644 (file)
@@ -547,6 +547,7 @@ endmenu
        source "package/ti-sgx-um/Config.in"
        source "package/ti-uim/Config.in"
        source "package/ti-utils/Config.in"
+       source "package/tio/Config.in"
        source "package/triggerhappy/Config.in"
        source "package/uboot-tools/Config.in"
        source "package/ubus/Config.in"
diff --git a/package/tio/Config.in b/package/tio/Config.in
new file mode 100644 (file)
index 0000000..6c748c5
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_TIO
+       bool "tio"
+       help
+         "tio" is a simple TTY terminal application which features a
+         straightforward commandline interface to easily connect to
+         TTY devices for basic input/output.
+
+         https://tio.github.io/
diff --git a/package/tio/tio.hash b/package/tio/tio.hash
new file mode 100644 (file)
index 0000000..3053bd1
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally computed:
+sha256 a8f5ed6994cacb96780baa416b19e5a6d7d67e8c162a8ea4fd9eccd64984ae44  tio-1.32.tar.xz
+
+# Hash for license files:
+sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
diff --git a/package/tio/tio.mk b/package/tio/tio.mk
new file mode 100644 (file)
index 0000000..31f1dfb
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# tio
+#
+################################################################################
+
+TIO_VERSION = 1.32
+TIO_SOURCE = tio-$(TIO_VERSION).tar.xz
+TIO_SITE = https://github.com/tio/tio/releases/download/v$(TIO_VERSION)
+TIO_LICENSE = GPL-2.0+
+TIO_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))