ncmpc: convert to pkg-meson infra
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Tue, 15 May 2018 19:51:57 +0000 (21:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 30 May 2018 20:20:19 +0000 (22:20 +0200)
Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ncmpc/ncmpc.mk

index 1d464b72de34d8742d6e5fda8d6a672be665f916..d70ed46ea99812b24239aa72fdca0fa6c4d909d0 100644 (file)
@@ -8,15 +8,11 @@ NCMPC_VERSION_MAJOR = 0
 NCMPC_VERSION = $(NCMPC_VERSION_MAJOR).29
 NCMPC_SOURCE = ncmpc-$(NCMPC_VERSION).tar.xz
 NCMPC_SITE = http://www.musicpd.org/download/ncmpc/$(NCMPC_VERSION_MAJOR)
-NCMPC_DEPENDENCIES = host-meson host-pkgconf libglib2 libmpdclient ncurses
+NCMPC_DEPENDENCIES = host-pkgconf libglib2 libmpdclient ncurses
 NCMPC_LICENSE = GPL-2.0+
 NCMPC_LICENSE_FILES = COPYING
 
-NCMPC_CONF_OPTS += \
-       --prefix=/usr \
-       -Dcurses=ncurses \
-       --buildtype $(if $(BR2_ENABLE_DEBUG),debug,release) \
-       --cross-file $(HOST_DIR)/etc/meson/cross-compilation.conf
+NCMPC_CONF_OPTS = -Dcurses=ncurses
 
 ifeq ($(BR2_PACKAGE_LIRC_TOOLS),y)
 NCMPC_DEPENDENCIES += lirc-tools
@@ -25,21 +21,4 @@ else
 NCMPC_CONF_OPTS += -Dlirc=false
 endif
 
-NCMPC_NINJA_OPTS = $(if $(VERBOSE),-v)
-
-define NCMPC_CONFIGURE_CMDS
-       rm -rf $(@D)/build
-       mkdir -p $(@D)/build
-       $(TARGET_MAKE_ENV) meson $(NCMPC_CONF_OPTS) $(@D) $(@D)/build
-endef
-
-define NCMPC_BUILD_CMDS
-       $(TARGET_MAKE_ENV) ninja $(NCMPC_NINJA_OPTS) -C $(@D)/build
-endef
-
-define NCMPC_INSTALL_TARGET_CMDS
-       $(TARGET_MAKE_ENV) DESTDIR=$(TARGET_DIR) \
-               ninja $(NCMPC_NINJA_OPTS) -C $(@D)/build install
-endef
-
-$(eval $(generic-package))
+$(eval $(meson-package))