python3: add optional dependency on bluez5_utils-headers
authorGrzegorz Blach <grzegorz@blach.pl>
Thu, 13 Sep 2018 11:56:56 +0000 (13:56 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 21 Oct 2018 15:42:50 +0000 (16:42 +0100)
When python3 depends on bluez5_utils-headers,
python3 is build with bluetooth support.

Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
[Arnout: select bluez5_utils-headers is bluez5_utils is enabled]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/python3/Config.in
package/python3/python3.mk

index 0701d56a6caf5ac34965ebd98c070f9f30b1c62e..6d77396380182a1109064d523028fe54942f4904 100644 (file)
@@ -11,6 +11,7 @@ config BR2_PACKAGE_PYTHON3
        depends on BR2_TOOLCHAIN_HAS_THREADS # libffi
        depends on !BR2_STATIC_LIBS
        select BR2_PACKAGE_LIBFFI
+       select BR2_PACKAGE_BLUEZ5_UTILS_HEADERS if BR2_PACKAGE_BLUEZ5_UTILS
        help
          The python language interpreter.
 
index 5e94e8e72628e8d4d6392bea143f1f67eb0c819c..efb44c04549717ee5c5ac1042ee323f927ca8978 100644 (file)
@@ -255,6 +255,11 @@ endif
 # Provided to other packages
 PYTHON3_PATH = $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/
 
+# Support for socket.AF_BLUETOOTH
+ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS_HEADERS),y)
+PYTHON3_DEPENDENCIES += bluez5_utils-headers
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))