toolchain-external: mark Synopsys toolchain as broken
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 May 2015 09:13:54 +0000 (11:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 May 2015 09:13:54 +0000 (11:13 +0200)
This uClibc toolchain does not provide an appropriate uClibc
configuration for Buildroot: missing IPv6, missing nsl stub, missing
program invocation, etc. Therefore, we mark it as broken, waiting for
a new upstream release of a new toolchain.

We keep around the toolchain-external Synopsys code anyway, since it
will most likely be identical for the new toolchain version. However,
we remove all the quirks that were introduced to start work around
issues related to this toolchain.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/exim/exim.mk
package/wvdial/Config.in
package/wvstreams/Config.in
toolchain/toolchain-external/Config.in

index 67dbd643e992118b75b30935926dcb8e107b96d8..ed309de1d6acd0b201af5d64f7203f1652bad96e 100644 (file)
@@ -70,13 +70,6 @@ define EXIM_USE_DEFAULT_CONFIG_FILE_OPENSSL
 endef
 endif
 
-# this specific toolchain lacks libnsl
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC_2014_12),y)
-define EXIM_REMOVE_LIBNSL_FROM_MAKEFILE
-       $(SED) 's/-lnsl//g' $(@D)/OS/Makefile-Linux
-endef
-endif
-
 define EXIM_CONFIGURE_TOOLCHAIN
        $(call exim-config-add,CC,$(TARGET_CC))
        $(call exim-config-add,CFLAGS,$(TARGET_CFLAGS))
index 14befcf809824f6624d4c55ffea5314725a1ddb9..e57f9755f756db3c1f6312a282bca3de9a64fe81 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_WVDIAL
        bool "wvdial"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_MMU # wvstreams
-       depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC_2014_12 # wvstreams
        select BR2_PACKAGE_WVSTREAMS
        help
          wvdial is an intelligent Point-to-Point Protocol dialer
@@ -12,4 +11,3 @@ config BR2_PACKAGE_WVDIAL
 comment "wvdial needs a toolchain w/ C++"
        depends on BR2_USE_MMU
        depends on !BR2_INSTALL_LIBSTDCPP
-       depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC_2014_12
index 0580516b3f6e614d5e4b20ad53c69a6cb7d1b7cc..3080dc71ef258ce834a4651dbb48051c02bf3276 100644 (file)
@@ -2,8 +2,6 @@ config BR2_PACKAGE_WVSTREAMS
        bool "wvstreams"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_MMU # fork()
-       # toolchain lacks program_invocation_*
-       depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC_2014_12
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_ZLIB
        help
@@ -14,4 +12,3 @@ config BR2_PACKAGE_WVSTREAMS
 comment "wvstreams needs a toolchain w/ C++"
        depends on BR2_USE_MMU
        depends on !BR2_INSTALL_LIBSTDCPP
-       depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC_2014_12
index 9433101ada6d4b43fb8afb67b74fba51c43773d6..665a15b1ae27ee8ff3aab24290edc586ae72a129 100644 (file)
@@ -837,6 +837,10 @@ config BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC_2014_12
        bool "Synopsys ARC 2014.12 toolchain"
        depends on BR2_arc
        depends on BR2_HOSTARCH = "x86_64"
+       # does not provide IPv6, and lacks many uClibc features
+       # expected by Buildroot. The next Synopsys toolchain version
+       # should fix those problems.
+       depends on BROKEN
        select BR2_TOOLCHAIN_EXTERNAL_UCLIBC
        select BR2_INSTALL_LIBSTDCPP
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC