libsigrok: enable building C++ bindings
authorBartosz Golaszewski <bgolaszewski@baylibre.com>
Mon, 23 Feb 2015 11:32:48 +0000 (12:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 Feb 2015 17:01:07 +0000 (18:01 +0100)
[Thomas:
 - Use BR2_INSTALL_LIBSTDCPP instead of BR2_TOOLCHAIN_BUILDROOT_CXX,
   so that the condition also works with external toolchains.
 - Use a 'if BR2_PACKAGE_LIBSIGROK' instead of duplicating the
   dependency.]

Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsigrok/Config.in
package/libsigrok/libsigrok.mk

index 47f812c952b0380f33757be5840e4a443e158f68..93bd06f7b4f336604ee3847acb2070ae75956cd8 100644 (file)
@@ -16,6 +16,21 @@ config BR2_PACKAGE_LIBSIGROK
 
          http://sigrok.org/wiki/Libsigrok
 
+if BR2_PACKAGE_LIBSIGROK
+
+config BR2_PACKAGE_LIBSIGROKCXX
+       bool "build C++ bindings"
+       select BR2_PACKAGE_GLIBMM
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Build libsigrok C++ bindings as well.
+
+comment "C++ bindings need a toolchain w/ C++"
+       depends on BR2_PACKAGE_LIBSIGROK
+       depends on !BR2_INSTALL_LIBSTDCPP
+
+endif
+
 comment "libsigrok needs a toolchain w/ wchar, threads"
        depends on BR2_USE_MMU
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
index 6bc210e074f313f80dca8231e1f84511b1dab306..1e6080d0990b71f99cb675364ef9b14b22c78565 100644 (file)
@@ -13,7 +13,7 @@ LIBSIGROK_LICENSE_FILES = COPYING
 LIBSIGROK_AUTORECONF = YES
 LIBSIGROK_INSTALL_STAGING = YES
 LIBSIGROK_DEPENDENCIES = libglib2 libzip host-pkgconf
-LIBSIGROK_CONF_OPTS = --disable-bindings --disable-glibtest
+LIBSIGROK_CONF_OPTS = --disable-glibtest --disable-java --disable-python
 
 define LIBSIGROK_ADD_MISSING
        mkdir -p $(@D)/autostuff
@@ -46,4 +46,11 @@ ifeq ($(BR2_PACKAGE_GLIBMM),y)
 LIBSIGROK_DEPENDENCIES += glibmm
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSIGROKCXX),y)
+LIBSIGROK_CONF_OPTS += --enable-cxx
+LIBSIGROK_DEPENDENCIES += host-autoconf-archive glibmm
+else
+LIBSIGROK_CONF_OPTS += --disable-cxx
+endif
+
 $(eval $(autotools-package))