python-pyparted: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 15 Jan 2016 08:57:41 +0000 (09:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Feb 2016 22:14:51 +0000 (23:14 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-pyparted/Config.in [new file with mode: 0644]
package/python-pyparted/python-pyparted.hash [new file with mode: 0644]
package/python-pyparted/python-pyparted.mk [new file with mode: 0644]

index 532b10a5698d29823c0d0c27919c2a158b2cbddb..529ad33649940751f847e74007dadcddd162cde8 100644 (file)
@@ -684,6 +684,7 @@ menu "External python modules"
        source "package/python-pygame/Config.in"
        source "package/python-pyinotify/Config.in"
        source "package/python-pyparsing/Config.in"
+       source "package/python-pyparted/Config.in"
        source "package/python-pypcap/Config.in"
        source "package/python-pyqt/Config.in"
        source "package/python-pyratemp/Config.in"
diff --git a/package/python-pyparted/Config.in b/package/python-pyparted/Config.in
new file mode 100644 (file)
index 0000000..1501595
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_PYTHON_PYPARTED
+       bool "python-pyparted"
+       depends on BR2_USE_WCHAR
+       select BR2_PACKAGE_PYTHON_CFFI # runtime
+       select BR2_PACKAGE_PARTED
+       help
+         Python bindings for GNU parted (libparted).
+
+         https://github.com/rhinstaller/pyparted
+
+comment "pyparted needs a toolchain w/ wchar"
+       depends on !BR2_USE_WCHAR
diff --git a/package/python-pyparted/python-pyparted.hash b/package/python-pyparted/python-pyparted.hash
new file mode 100644 (file)
index 0000000..a2adc41
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256  5914e3a60437fe3e3758a9e86ee4a539dfa46cfe18e3df386a5cf1f75a963431  python-pyparted-v3.10.7.tar.gz
diff --git a/package/python-pyparted/python-pyparted.mk b/package/python-pyparted/python-pyparted.mk
new file mode 100644 (file)
index 0000000..4bf58c4
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-pyparted
+#
+################################################################################
+
+PYTHON_PYPARTED_VERSION = v3.10.7
+PYTHON_PYPARTED_SITE = $(call github,rhinstaller,pyparted,$(PYTHON_PYPARTED_VERSION))
+PYTHON_PYPARTED_SETUP_TYPE = distutils
+PYTHON_PYPARTED_LICENSE = GPLv2+
+PYTHON_PYPARTED_LICENSE_FILES = COPYING
+PYTHON_PYPARTED_DEPENDENCIES = host-python-cffi parted
+
+$(eval $(python-package))