xorg-server: add dependency on dri2proto when systemd is built
authorFabien Parent <fparent@baylibre.com>
Tue, 29 Nov 2016 14:36:58 +0000 (15:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Dec 2016 13:25:39 +0000 (14:25 +0100)
When systemd is selected, xorg-server must have config-udev-kms
enabled in order to build correctly, but it won't be the case if
BR2_PACKAGE_XPROTO_DRI2PROTO is not part of the build.

Add BR2_PACKAGE_XPROTO_DRI2PROTO as a dependency of xorg-xserver
only when systemd is part of the build.

Fixes bug #9486.

Signed-off-by: Fabien Parent <fparent@baylibre.com>
Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index 1d4a1fb5ee7547b4d3cdac4689ce097e0ddb6d43..b7f2b3eb4a84b5f2e336345c31e2fdfeae7ce2b8 100644 (file)
@@ -47,6 +47,7 @@ config BR2_PACKAGE_XSERVER_XORG_SERVER
        select BR2_PACKAGE_XPROTO_XPROTO
        select BR2_PACKAGE_XUTIL_UTIL_MACROS
        select BR2_PACKAGE_XKEYBOARD_CONFIG
+       select BR2_PACKAGE_XPROTO_DRI2PROTO if BR2_PACKAGE_SYSTEMD
        help
          X.Org X server
 
index 6519af3d737b9f6cd308fa7ee2f59c585552cbc7..6444a206bcc66b86b87f080affb524b8483cb377 100644 (file)
@@ -72,7 +72,9 @@ ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 XSERVER_XORG_SERVER_CONF_OPTS += \
        --with-systemd-daemon \
        --enable-systemd-logind
-XSERVER_XORG_SERVER_DEPENDENCIES += systemd
+XSERVER_XORG_SERVER_DEPENDENCIES += \
+       systemd \
+       xproto_dri2proto
 else
 XSERVER_XORG_SERVER_CONF_OPTS += \
        --without-systemd-daemon \