package infra: drop non-IPv6 support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 19 Apr 2015 12:40:01 +0000 (09:40 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Apr 2015 21:06:55 +0000 (23:06 +0200)
Now that IPv6 is mandatory remove support for non-IPv6 tweaks/variables
in the package infra.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in
package/pkg-autotools.mk

index e65e08b3360f969e17476f6380d860ffbe725aa8..a0c5a7a48d236312b538be4b601b9c8f4e80c582 100644 (file)
@@ -369,12 +369,6 @@ else
 DISABLE_NLS :=--disable-nls
 endif
 
-ifeq ($(BR2_INET_IPV6),y)
-DISABLE_IPV6 = --enable-ipv6
-else
-DISABLE_IPV6 = --disable-ipv6
-endif
-
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 TARGET_CONFIGURE_OPTS += CXX=false
 endif
index 2ecf7d82733eb108269fb81c41091382cdc25f35..49b42d443b33a668944ea985e77d174d1932a50f 100644 (file)
@@ -200,8 +200,8 @@ define $(2)_CONFIGURE_CMDS
                --with-xmlto=no \
                --with-fop=no \
                --disable-dependency-tracking \
+               --enable-ipv6 \
                $$(DISABLE_NLS) \
-               $$(DISABLE_IPV6) \
                $$(ENABLE_DEBUG) \
                $$(SHARED_STATIC_LIBS_OPTS) \
                $$(QUIET) $$($$(PKG)_CONF_OPTS) \