package/rcw: add missing host-python dependency
authorLaurent Hartanerot <laurent.hartanerot@atos.net>
Thu, 19 Mar 2020 09:30:57 +0000 (10:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 21 Mar 2020 15:36:17 +0000 (16:36 +0100)
The rcw tool that compiles RCW sources file need host-python

Signed-off-by: Laurent Hartanerot <laurent.hartanerot@atos.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rcw/rcw.mk

index 81e22fff93850d32413c83b46c2e2c7a5ca398e1..dbfeae7b212219d7462d789a9aaaa677d8e1c41f 100644 (file)
@@ -10,6 +10,8 @@ RCW_SITE_METHOD = git
 RCW_LICENSE = BSD-3-Clause
 RCW_LICENSE_FILES = LICENSE
 
+HOST_RCW_DEPENDENCIES = host-python
+
 RCW_FILES = $(call qstrip,$(BR2_PACKAGE_HOST_RCW_CUSTOM_PATH))
 
 ifneq ($(RCW_FILES),)
@@ -39,7 +41,9 @@ endef
 HOST_RCW_POST_PATCH_HOOKS += HOST_RCW_ADD_CUSTOM_RCW_FILES
 
 define HOST_RCW_BUILD_CMDS
-       python $(@D)/rcw.py -i $(@D)/custom_board/rcw/$(RCW_PROJECT) -I $(@D)/custom_board -o $(@D)/PBL.bin
+       $(HOST_DIR)/bin/python $(@D)/rcw.py \
+               -i $(@D)/custom_board/rcw/$(RCW_PROJECT) \
+               -I $(@D)/custom_board -o $(@D)/PBL.bin
 endef
 
 define HOST_RCW_INSTALL_DELIVERY_FILE