Makefile: out-of-tree fix for uclibc 0.9.31
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 5 Apr 2010 08:44:54 +0000 (10:44 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 5 Apr 2010 08:44:54 +0000 (10:44 +0200)
Strangely enough O is still passed to submakes with MAKEOVERRIDES
(with make 3.81 atleast), the only thing that changes is the output
of the origin function (command line -> environment).
Unfortunately some packages don't look at origin (E.G. uClibc 0.9.31+)
To really make O go away, we have to override it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index b746934f9e497b7deaef1ac09b74f54c43ebae72..b47c0b0dd4f5c6352f0837f4a028bb29878c8489 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -230,6 +230,12 @@ else
 # forwards command line variable definitions those packages get very
 # confused. Fix this by telling make to not do so
 MAKEOVERRIDES =
+# strangely enough O is still passed to submakes with MAKEOVERRIDES
+# (with make 3.81 atleast), the only thing that changes is the output
+# of the origin function (command line -> environment).
+# Unfortunately some packages don't look at origin (E.G. uClibc 0.9.31+)
+# To really make O go away, we have to override it.
+override O:=$(O)
 endif
 
 # bash prints the name of the directory on 'cd <dir>' if CDPATH is