uboot: remove unused helper function insert_define
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Wed, 6 Jan 2016 13:33:18 +0000 (14:33 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 18 Jan 2016 09:10:50 +0000 (10:10 +0100)
Commit 16b8e813c810fde2fe3655c696edf1e76a7d27ba removed all remaining users
of helper function insert_define.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/uboot/uboot.mk

index c8c50f00747bdf162ff35d6ef2bd1c07e557f1dc..d539b3123aef61e272e3313036cc4f21562c5351 100644 (file)
@@ -89,18 +89,6 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)
 UBOOT_DEPENDENCIES += host-dtc
 endif
 
-# Helper function to fill the U-Boot config.h file.
-# Argument 1: option name
-# Argument 2: option value
-# If the option value is empty, this function does nothing.
-define insert_define
-$(if $(call qstrip,$(2)),
-       @echo "#ifdef $(strip $(1))" >> $(@D)/include/config.h
-       @echo "#undef $(strip $(1))" >> $(@D)/include/config.h
-       @echo "#endif" >> $(@D)/include/config.h
-       @echo '#define $(strip $(1)) $(call qstrip,$(2))' >> $(@D)/include/config.h)
-endef
-
 # prior to u-boot 2013.10 the license info was in COPYING. Copy it so
 # legal-info finds it
 define UBOOT_COPY_OLD_LICENSE_FILE