dnsmasq: add sysv initscript
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 29 Mar 2014 09:01:02 +0000 (06:01 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Mar 2014 10:41:14 +0000 (11:41 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dnsmasq/S80dnsmasq [new file with mode: 0755]
package/dnsmasq/dnsmasq.mk

diff --git a/package/dnsmasq/S80dnsmasq b/package/dnsmasq/S80dnsmasq
new file mode 100755 (executable)
index 0000000..2ff0206
--- /dev/null
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+[ -x /usr/sbin/dnsmasq ] || exit 0
+[ -f /etc/dnsmasq.conf ] || exit 0
+
+case "$1" in
+       start)
+               echo -n "Starting dnsmasq: "
+               start-stop-daemon -S -x /usr/sbin/dnsmasq
+               [ $? == 0 ] && echo "OK" || echo "FAIL"
+               ;;
+       stop)
+               echo -n "Stopping dnsmasq: "
+               start-stop-daemon -K -q -x /usr/sbin/dnsmasq
+               [ $? == 0 ] && echo "OK" || echo "FAIL"
+               ;;
+       restart|reload)
+               $0 stop
+               $0 start
+               ;;
+       *)
+               echo "Usage: $0 {start|stop|restart}"
+               exit 1
+esac
+
+exit 0
index 9bf9b84a402c18e9abc0a04bef2a783b864c236d..56d11eeb61253e9524314124a379ddaccec6ad00 100644 (file)
@@ -93,4 +93,9 @@ define DNSMASQ_INSTALL_TARGET_CMDS
        mkdir -p $(TARGET_DIR)/var/lib/misc/
 endef
 
+define DNSMASQ_INSTALL_INIT_SYSV
+       $(INSTALL) -m 755 -D package/dnsmasq/S80dnsmasq \
+               $(TARGET_DIR)/etc/init.d/S80dnsmasq
+endef
+
 $(eval $(generic-package))