toolchain/uclibc: only use make install_headers for 0.9.29+
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Oct 2008 15:23:50 +0000 (15:23 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Oct 2008 15:23:50 +0000 (15:23 -0000)
0.9.28.3 doesn't have install_headers, so use install_dev there.

Got broken by r23561.

toolchain/uClibc/uclibc.mk

index 0eb9f64466ba198b12fee5b3db531fb67d2ed3b7..31ac84f21729880c2faae20d9647a10f78dc6f5b 100644 (file)
@@ -434,7 +434,11 @@ $(UCLIBC_DIR)/.configured: $(LINUX_HEADERS_DIR)/.configured $(UCLIBC_DIR)/.confi
                DEVEL_PREFIX=/usr/ \
                RUNTIME_PREFIX=$(TOOL_BUILD_DIR)/uClibc_dev/ \
                HOSTCC="$(HOSTCC)" \
+ifeq ($(BR2_UCLIBC_VERSION_0_9_28_3),y)
+               headers install_dev
+else
                headers install_headers
+endif
        # Install the kernel headers to the first stage gcc include dir
        # if necessary
 ifeq ($(LINUX_HEADERS_IS_KERNEL),y)