openswan: add missing TARGET_MAKE_ENV
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Mar 2013 21:51:55 +0000 (21:51 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Mar 2013 07:57:15 +0000 (08:57 +0100)
openswan needs host-bison. The dependency was already there, but the
build was not executed with $(TARGET_MAKE_ENV) in the environment, and
therefore $(HOST_DIR)/usr/bin was not in the PATH.

While we're at it, add licensing informations to openswan.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/openswan/openswan.mk

index 781dc004131f787ba4dbc7587ed58decf3539a67..153d6590f121e1b90e02c5f4db61f3279ed5ad05 100644 (file)
@@ -6,6 +6,9 @@
 
 OPENSWAN_VERSION = 2.6.38
 OPENSWAN_SITE = http://download.openswan.org/openswan
+OPENSWAN_LICENSE = GPLv2+, BSD-3c
+OPENSWAN_LICENSE_FILES = COPYING LICENSE
+
 OPENSWAN_DEPENDENCIES = host-bison gmp iproute2
 OPENSWAN_MAKE_OPT = ARCH=$(BR2_ARCH) CC="$(TARGET_CC)" \
        USERCOMPILE="$(TARGET_CFLAGS)" INC_USRLOCAL=/usr \
@@ -25,11 +28,13 @@ endif
 endif
 
 define OPENSWAN_BUILD_CMDS
-       $(MAKE) -C $(@D) $(OPENSWAN_MAKE_OPT) programs
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(OPENSWAN_MAKE_OPT) programs
 endef
 
 define OPENSWAN_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) $(OPENSWAN_MAKE_OPT) DESTDIR=$(TARGET_DIR) install
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               $(OPENSWAN_MAKE_OPT) DESTDIR=$(TARGET_DIR) install
 endef
 
 $(eval $(generic-package))