uclibc, eglibc: remove REALLY_NOSTDLIB references
authorMischa Jonker <mischa.jonker@synopsys.com>
Thu, 18 Jul 2013 21:47:50 +0000 (23:47 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 19 Jul 2013 09:54:28 +0000 (11:54 +0200)
These were required with ARC gcc 4.4.7; ARC gcc 4.8 has been changed
to behave the same as other architectures with -nostdlib, making this
option obsolete.

Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/eglibc/eglibc.mk
package/uclibc/uclibc.mk

index ccdc2109d3a277c2e595a6471c563c8cf614d125..5431ac574c33806af118e6e3eaa8f93e429fe35c 100644 (file)
@@ -61,7 +61,7 @@ define EGLIBC_CONFIGURE_CMDS
        cp $(@D)/build/csu/crt1.o $(STAGING_DIR)/usr/lib/
        cp $(@D)/build/csu/crti.o $(STAGING_DIR)/usr/lib/
        cp $(@D)/build/csu/crtn.o $(STAGING_DIR)/usr/lib/
-       $(TARGET_CROSS)gcc -nostdlib $(REALLY_NOSTDLIB) \
+       $(TARGET_CROSS)gcc -nostdlib \
                -nostartfiles -shared -x c /dev/null -o $(STAGING_DIR)/usr/lib/libc.so
 endef
 
index f775b15601a712db6f006f0556585fdd402052aa..d5ea7a4b76b52f2a29461ec10ccaaa7ade28caee 100644 (file)
@@ -162,13 +162,6 @@ define UCLIBC_X86_TYPE_CONFIG
 endef
 endif
 
-#
-# ARC definitions
-#
-ifeq ($(UCLIBC_TARGET_ARCH),arc)
-REALLY_NOSTDLIB = -really-nostdlib
-endif
-
 #
 # Endianess
 #
@@ -407,9 +400,9 @@ define UCLIBC_CONFIGURE_CMDS
                RUNTIME_PREFIX=$(STAGING_DIR) \
                headers lib/crt1.o lib/crti.o lib/crtn.o \
                install_headers
-       $(TARGET_CROSS)gcc -nostdlib $(REALLY_NOSTDLIB) \
+       $(TARGET_CROSS)gcc -nostdlib \
                -nostartfiles -shared -x c /dev/null -o $(STAGING_DIR)/usr/lib/libc.so
-       $(TARGET_CROSS)gcc -nostdlib $(REALLY_NOSTDLIB) \
+       $(TARGET_CROSS)gcc -nostdlib \
                -nostartfiles -shared -x c /dev/null -o $(STAGING_DIR)/usr/lib/libm.so
        cp -pLR $(UCLIBC_DIR)/lib/crt[1in].o $(STAGING_DIR)/usr/lib/
 endef