vim: selinux support
authorMatt Weber <matthew.weber@rockwellcollins.com>
Tue, 2 Jun 2015 13:28:31 +0000 (08:28 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Jul 2015 08:19:11 +0000 (10:19 +0200)
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Reviewed-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vim/vim.mk

index da84d14d8f57393bd3f63492f3781ca13391c634..518afafdce9f65f0e1e62bc27d45c6b9a94e2d42 100644 (file)
@@ -28,6 +28,13 @@ VIM_CONF_OPTS = --with-tlib=ncurses --enable-gui=no --without-x
 VIM_LICENSE = Charityware
 VIM_LICENSE_FILES = README.txt
 
+ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
+VIM_CONF_OPTS += --enable-selinux
+VIM_DEPENDENCIES += libselinux
+else
+VIM_CONF_OPTS += --disable-selinux
+endif
+
 define VIM_INSTALL_TARGET_CMDS
        cd $(@D)/src; \
                $(MAKE) DESTDIR=$(TARGET_DIR) installvimbin; \