exiv2: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 10:26:53 +0000 (12:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:25 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using BR2_SYSTEM_ENABLE_NLS instead of BR2_ENABLE_LOCALE to decide
   if NLS support should be enabled or not

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/exiv2/exiv2.mk

index 6bc88482c6ab9b194287a7a923cbd621a3c0607d..32029bab97ae2e911c7f92bad0ec2edd66543924 100644 (file)
@@ -42,11 +42,10 @@ else
 EXIV2_CONF_OPTS += -DEXIV2_ENABLE_XMP=OFF -DEXIV2_ENABLE_LIBXMP=OFF
 endif
 
-ifeq ($(BR2_ENABLE_LOCALE),y)
+EXIV2_DEPENDENCIES += $(TARGET_NLS_DEPENDENCIES)
+
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
 EXIV2_CONF_OPTS += -DEXIV2_ENABLE_NLS=ON
-ifeq ($(BR2_PACKAGE_GETTEXT),y)
-EXIV2_DEPENDENCIES += gettext
-endif
 else
 EXIV2_CONF_OPTS += -DEXIV2_ENABLE_NLS=OFF
 endif