binutils: add microblaze internal toolchain
authorSpenser Gilliland <spenser@gillilanding.com>
Thu, 5 Dec 2013 17:20:52 +0000 (18:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 6 Dec 2013 21:45:25 +0000 (22:45 +0100)
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/binutils/Config.in.host
package/binutils/binutils.mk

index ef833eca2a5360d072dc45c855213414badf1c7e..a8e1e454d3385f5f52bc80babeb2db00bff7abbe 100644 (file)
@@ -3,6 +3,7 @@ comment "Binutils Options"
 choice
        prompt "Binutils Version"
        depends on !BR2_arc
+       depends on !BR2_microblaze
        default BR2_BINUTILS_VERSION_2_21 if (BR2_mips || BR2_mipsel || BR2_sh)
        default BR2_BINUTILS_VERSION_2_22
        help
@@ -49,6 +50,7 @@ config BR2_BINUTILS_VERSION
        string
        default "2.18-avr32-1.0.1" if BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
        default "0c824ba511fa9b028220eb3c39b566af89ac9dda" if BR2_arc
+       default "8351467c933d277ebea0c8d99ad2b65b5f7b6bc2" if BR2_microblaze
        default "2.20.1"        if BR2_BINUTILS_VERSION_2_20_1
        default "2.21"          if BR2_BINUTILS_VERSION_2_21
        default "2.21.1"        if BR2_BINUTILS_VERSION_2_21_1
index 3c148492791d8d363a2a94964de5ec5f2e4ea0b1..13854b0673103a34ac93d865a15b52a914008629 100644 (file)
@@ -27,6 +27,10 @@ ifeq ($(BR2_arc),y)
 BINUTILS_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,binutils,$(BINUTILS_VERSION))
 BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz
 endif
+ifeq ($(BR2_microblaze),y)
+BINUTILS_SITE = $(call github,Xilinx,binutils,$(BINUTILS_VERSION))
+BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.gz
+endif
 BINUTILS_SITE ?= $(BR2_GNU_MIRROR)/binutils
 BINUTILS_SOURCE ?= binutils-$(BINUTILS_VERSION).tar.bz2
 BINUTILS_EXTRA_CONFIG_OPTIONS = $(call qstrip,$(BR2_BINUTILS_EXTRA_CONFIG_OPTIONS))