package: fix fallout from checking kconfig config files
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 14 Jul 2015 10:13:21 +0000 (12:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 10:20:49 +0000 (12:20 +0200)
Those checks should only be done when the package is actually enabled.

Reported-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/busybox.mk
package/uclibc/uclibc.mk

index d8c8bad318b5e4d70be0dca4b547205183e15627..6b2abcacbf0b37f35264729880d8c55d7b12eec5 100644 (file)
@@ -225,7 +225,7 @@ endef
 
 # Checks to give errors that the user can understand
 # Must be before we call to kconfig-package
-ifeq ($(BR_BUILDING),y)
+ifeq ($(BR2_PACKAGE_BUSYBOX)$(BR_BUILDING),yy)
 ifeq ($(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG)),)
 $(error No BusyBox configuration file specified, check your BR2_PACKAGE_BUSYBOX_CONFIG setting)
 endif
index 3aceae300cce85440df31965b09ed596cb591c55..9dfafad457e8887ba8bc09e0f4e01a9b2241ae6d 100644 (file)
@@ -476,7 +476,7 @@ endef
 
 # Checks to give errors that the user can understand
 # Must be before we call to kconfig-package
-ifeq ($(BR_BUILDING),y)
+ifeq ($(BR2_PACKAGE_UCLIBC)$(BR_BUILDING),yy)
 ifeq ($(call qstrip,$(BR2_UCLIBC_CONFIG)),)
 $(error No uClibc configuration file specified, check your BR2_UCLIBC_CONFIG setting)
 endif