u-boot: fix target build of fw_printenv
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 21:32:46 +0000 (23:32 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 21:32:46 +0000 (23:32 +0200)
Closes #3571

The current approach for building fw_printenv for the target fails on
some configurations, so use the upstream make target (which works)
instead.

At the same time get rid of the unneeded stripping.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
boot/u-boot/u-boot.mk

diff --git a/CHANGES b/CHANGES
index 07e4935126220e6f6d42b440c534e50af10df016..19d2cc518f90e78d70168be78c343ba4d1c35629 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -19,6 +19,7 @@
        #3475: Calling sync on large filesystems when not always necessary
        #3511: make busybox-menuconfig does not download busybox package
        #3541: Quotes in the top Makefile:217 break buildroot/kernel config...
+       #3571: u-boot: fw_printenv does not build
        #3643: popt source url is not responding
 
 2011.02, Released February 28th, 2011:
index 2f839c53c9f297e5f0d65f28f88690fe8dd0f278..ff3f65e96a7c51e8bb362d36c3c5e0b7a271ab1f 100644 (file)
@@ -159,15 +159,11 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/.configured
                $(U_BOOT_DIR)/tools/os_support.c \
                $(wildcard $(U_BOOT_DIR)/libfdt/fdt*.c $(U_BOOT_DIR)/lib/libfdt/fdt*.c)
 
-       $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
-
 # Build manually fw_printenv for the target
 $(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/.configured
-       mkdir -p $(@D)
-       $(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \
-               -DUSE_HOSTCC -o $@ \
-               $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/lib*/crc32.c
-       $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
+       $(TARGET_CONFIGURE_OPTS) \
+               $(MAKE) HOSTCC="$(TARGET_CC)" -C $(U_BOOT_DIR) env
+       $(INSTALL) -m 0755 -D $(U_BOOT_DIR)/tools/env/fw_printenv $@
        ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv
 
 u-boot: $(U_BOOT_TARGETS)