mutt: add libidn2 support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 23 Jul 2018 18:17:13 +0000 (20:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Jul 2018 21:01:01 +0000 (23:01 +0200)
libidn2 support was added in version 1.10: http://www.mutt.org/relnotes/1.10
libidn and libidn2 can't be selected at the same time: see configure.ac

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mutt/mutt.mk

index 1a2c5342d72dfb07d4b178dccb254e5237075fc3..1c3021ece1ba8c715fa10d9eccf0176d16d86d35 100644 (file)
@@ -16,11 +16,15 @@ MUTT_DEPENDENCIES += libiconv
 MUTT_CONF_OPTS += --enable-iconv
 endif
 
-ifeq ($(BR2_PACKAGE_LIBIDN),y)
+# Both options can't be selected at the same time so prefer libidn2
+ifeq ($(BR2_PACKAGE_LIBIDN2),y)
+MUTT_DEPENDENCIES += libidn2
+MUTT_CONF_OPTS += --with-idn2 --without-idn
+else ifeq ($(BR2_PACKAGE_LIBIDN),y)
 MUTT_DEPENDENCIES += libidn
-MUTT_CONF_OPTS += --with-idn
+MUTT_CONF_OPTS += --with-idn --without-idn2
 else
-MUTT_CONF_OPTS += --without-idn
+MUTT_CONF_OPTS += --without-idn --without-idn2
 endif
 
 ifeq ($(BR2_PACKAGE_MUTT_IMAP),y)