package/gnupg2: add optional support for sqlite
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Mar 2017 11:33:27 +0000 (12:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Mar 2017 20:46:46 +0000 (21:46 +0100)
Also add host-pkgconf to detect sqlite support, otherwise

checking pkg-config is at least version 0.9.0...
 ./configure: line 7981: /home/buildroot/br2/output/host/usr/bin/pkg-config: No such file or directory
no
[...]
checking for SQLITE3... no

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnupg2/gnupg2.mk

index 55190cc80ef8edfd223b4842c794de5032e4f4b7..d7f277cdfe51287fab3b464938d44726dffa14f7 100644 (file)
@@ -10,7 +10,7 @@ GNUPG2_SITE = ftp://ftp.gnupg.org/gcrypt/gnupg
 GNUPG2_LICENSE = GPLv3+
 GNUPG2_LICENSE_FILES = COPYING
 GNUPG2_DEPENDENCIES = zlib libgpg-error libgcrypt libassuan libksba libnpth \
-       $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+       $(if $(BR2_PACKAGE_LIBICONV),libiconv) host-pkgconf
 
 GNUPG2_CONF_OPTS = \
        --disable-rpath --disable-regex --disable-doc \
@@ -49,4 +49,11 @@ else
 GNUPG2_CONF_OPTS += --without-readline
 endif
 
+ifeq ($(BR2_PACKAGE_SQLITE),y)
+GNUPG2_CONF_OPTS += --enable-sqlite
+GNUPG2_DEPENDENCIES += sqlite
+else
+GNUPG2_CONF_OPTS += --disable-sqlite
+endif
+
 $(eval $(autotools-package))