boot/uboot: add option to build u-boot.itb image
authorDario Binacchi <dariobin@libero.it>
Tue, 3 Dec 2019 21:36:22 +0000 (22:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Dec 2019 21:22:08 +0000 (22:22 +0100)
It allows you to add the u-boot.itb to the list of U-Boot images that
can be created. Like the others, this one is also copied to the image
folder.

Signed-off-by: Dario Binacchi <dariobin@libero.it>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index 68a915cdaef658a5facff9693e2ff7fac4fc75e3..15cae8045a434a265c7a0ad400c45ee61e523a64 100644 (file)
@@ -225,6 +225,9 @@ config BR2_TARGET_UBOOT_FORMAT_DTB_IMX
 config BR2_TARGET_UBOOT_FORMAT_IMG
        bool "u-boot.img"
 
+config BR2_TARGET_UBOOT_FORMAT_ITB
+       bool "u-boot.itb"
+
 config BR2_TARGET_UBOOT_FORMAT_IMX
        bool "u-boot.imx"
 
index 5e0f6140246490946d660086de529a8abca10a9d..0ebda6588c28b7cbb4733dcc93b47d086d4eabbc 100644 (file)
@@ -85,6 +85,11 @@ UBOOT_BINS += u-boot.img
 UBOOT_MAKE_TARGET += u-boot.img
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_FORMAT_ITB),y)
+UBOOT_BINS += u-boot.itb
+UBOOT_MAKE_TARGET += u-boot.itb
+endif
+
 ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMX),y)
 UBOOT_BINS += u-boot.imx
 UBOOT_MAKE_TARGET += u-boot.imx