gmp: disable assembly for arc
authorZakharov Vlad <Vladislav.Zakharov@synopsys.com>
Mon, 15 Aug 2016 14:41:47 +0000 (17:41 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 16 Aug 2016 05:53:41 +0000 (07:53 +0200)
It has different inline assembly constraints that
are not supported after update to gcc-6.

Fixes:
http://autobuild.buildroot.net/results/c91/c9143eec0834017d57d5352d6fc95b5fae38da00//
and a lot of other failures of gmp-6.1.1 for ARC.

Signed-off-by: Vlad Zakharov <vzakhar@synopsys.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gmp/gmp.mk

index 485bf7c0f36285be7bc26cdd22bdd237092cffb0..420fd2f3fd0bfb184bee928f665e99f41aca5f45 100644 (file)
@@ -15,7 +15,7 @@ HOST_GMP_DEPENDENCIES = host-m4
 
 # GMP doesn't support assembly for coldfire or mips r6 ISA yet
 # Disable for ARM v7m since it has different asm constraints
-ifeq ($(BR2_m68k_cf)$(BR2_mips_32r6)$(BR2_mips_64r6)$(BR2_ARM_CPU_ARMV7M),y)
+ifeq ($(BR2_m68k_cf)$(BR2_mips_32r6)$(BR2_mips_64r6)$(BR2_ARM_CPU_ARMV7M)$(BR2_arc),y)
 GMP_CONF_OPTS += --disable-assembly
 endif