qt5base: install bundled fonts to target
authorFloris Bos <bos@je-eigen-domein.nl>
Tue, 19 Mar 2013 09:29:41 +0000 (09:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Mar 2013 21:41:48 +0000 (22:41 +0100)
If not using font-config, Qt 5 offers a set of standard fonts to
use instead. Install these to target.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/qt5base/qt5base.mk

index 3b4c007a0bec0edc155a59c16953239abc3df088..83ce9998ce85684b9b2a07d47e940b454218a2db 100644 (file)
@@ -172,9 +172,17 @@ define QT5BASE_INSTALL_TARGET_PLUGINS
        fi
 endef
 
+define QT5BASE_INSTALL_TARGET_FONTS
+       if [ -d $(STAGING_DIR)/usr/lib/fonts/ ] ; then \
+               mkdir -p $(TARGET_DIR)/usr/lib/fonts ; \
+               cp -dpfr $(STAGING_DIR)/usr/lib/fonts/* $(TARGET_DIR)/usr/lib/fonts ; \
+       fi
+endef
+
 define QT5BASE_INSTALL_TARGET_CMDS
        $(QT5BASE_INSTALL_TARGET_LIBS)
        $(QT5BASE_INSTALL_TARGET_PLUGINS)
+       $(QT5BASE_INSTALL_TARGET_FONTS)
 endef
 
 $(eval $(generic-package))