polarssl: security bump to version 1.2.6
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 28 Mar 2013 01:34:07 +0000 (01:34 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 1 Apr 2013 19:01:44 +0000 (21:01 +0200)
Fixes CVE-2013-0169.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/polarssl/polarssl-shared-and-static-library.patch
package/polarssl/polarssl.mk

index 8f7ce5f5b8e4623b16c8b9723afae30c2c8f383c..f4f47463069b6edba5953b8b9d409544eb16f436 100644 (file)
@@ -9,7 +9,7 @@ This patch adds the USE_STATIC_POLARSSL_LIBRARY (which defaults to ON)
 in addition to the existing USE_SHARED_POLARSSL_LIBRARY (which
 defaults to OFF). Both options can be manipulated independently.
 
-[Gustavo: update for polarssl 1.2.5]
+[Gustavo: update for polarssl 1.2.6]
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 
@@ -34,7 +34,7 @@ diff -Nura polarssl-1.2.3.orig/library/CMakeLists.txt polarssl-1.2.3/library/CMa
 +if(USE_SHARED_POLARSSL_LIBRARY)
  
  add_library(polarssl SHARED ${src})
- set_target_properties(polarssl PROPERTIES VERSION 1.2.5 SOVERSION 2)
+ set_target_properties(polarssl PROPERTIES VERSION 1.2.6 SOVERSION 2)
 +set_target_properties(polarssl PROPERTIES OUTPUT_NAME polarssl)
 +
 +endif(USE_SHARED_POLARSSL_LIBRARY)
index 0478f8a3de66dff30fb00b0c9ea075395e26eb39..c05a30769634b275bf1aba634b54c258975e35d2 100644 (file)
@@ -1,5 +1,5 @@
 POLARSSL_SITE = https://polarssl.org/download
-POLARSSL_VERSION = 1.2.5
+POLARSSL_VERSION = 1.2.6
 POLARSSL_SOURCE = polarssl-$(POLARSSL_VERSION)-gpl.tgz
 POLARSSL_CONF_OPT = \
        -DUSE_SHARED_POLARSSL_LIBRARY=ON \