projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f2a5ce4
)
Support building a cross libtool for use on the host during cross-development.
author
Eric Andersen
<andersen@codepoet.org>
Fri, 30 Sep 2005 20:46:29 +0000
(20:46 -0000)
committer
Eric Andersen
<andersen@codepoet.org>
Fri, 30 Sep 2005 20:46:29 +0000
(20:46 -0000)
package/libtool/libtool.mk
patch
|
blob
|
history
diff --git
a/package/libtool/libtool.mk
b/package/libtool/libtool.mk
index 5d6c98d57511fbec32f2dccd555ef91886cde883..1befd2e97a586b43ce62d68785207cf36b2eb5b4 100644
(file)
--- a/
package/libtool/libtool.mk
+++ b/
package/libtool/libtool.mk
@@
-73,6
+73,11
@@
libtool-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(LIBTOOL_DIR) uninstall
-$(MAKE) -C $(LIBTOOL_DIR) clean
+libtool-cross: uclibc $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
+
+libtool-cross-clean:
+ -$(MAKE) -C $(LIBTOOL_DIR) clean
+
libtool-dirclean:
rm -rf $(LIBTOOL_DIR)