comment "Legacy options removed in 2019.11"
+config BR2_PACKAGE_RPI_USERLAND_START_VCFILED
+ bool "rpi-userland start vcfiled was removed"
+ select BR2_LEGACY
+ help
+ The vcfiled support was removed upstream.
+
config BR2_PACKAGE_ALLJOYN
bool "alljoyn was removed"
select BR2_LEGACY
-From 8275a380658070336df0c404f0ff585d27681836 Mon Sep 17 00:00:00 2001
+From cc9ac86bcff79697d354cc51d3a984fd0f362868 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Thu, 22 Sep 2016 22:59:11 +0200
Subject: [PATCH] Disable Werror everywhere
[Rebased for rpi-userland-8f0abfb07b96e7ee85f46e59d895014ec5e25f5e]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+
+[Rebased for rpi-userland-5070cb7fc150fc98f1ed64a7739c3356970d9f76]
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
host_applications/android/apps/vidtex/CMakeLists.txt | 2 +-
host_applications/linux/apps/gencmd/CMakeLists.txt | 2 +-
interface/vcos/CMakeLists.txt | 2 +-
interface/vcos/pthreads/CMakeLists.txt | 2 +-
interface/vmcs_host/CMakeLists.txt | 2 +-
- interface/vmcs_host/linux/vcfiled/CMakeLists.txt | 2 +-
- 11 files changed, 11 insertions(+), 11 deletions(-)
+ 10 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/host_applications/android/apps/vidtex/CMakeLists.txt b/host_applications/android/apps/vidtex/CMakeLists.txt
index 6d66d69..06a3192 100644
include_directories( ../../../..
diff --git a/host_applications/linux/apps/raspicam/CMakeLists.txt b/host_applications/linux/apps/raspicam/CMakeLists.txt
-index 42636e8..d778f09 100644
+index f7db21e..b94bdc3 100644
--- a/host_applications/linux/apps/raspicam/CMakeLists.txt
+++ b/host_applications/linux/apps/raspicam/CMakeLists.txt
@@ -1,7 +1,7 @@
include_directories( ../../../..
diff --git a/interface/mmal/CMakeLists.txt b/interface/mmal/CMakeLists.txt
-index 37ae757..78b24a9 100644
+index 46f149d..06273dc 100644
--- a/interface/mmal/CMakeLists.txt
+++ b/interface/mmal/CMakeLists.txt
@@ -3,7 +3,7 @@ if (NOT DEFINED LIBRARY_TYPE)
endif ()
diff --git a/interface/vmcs_host/CMakeLists.txt b/interface/vmcs_host/CMakeLists.txt
-index fde18da..802c158 100755
+index a157db1..dc384ca 100755
--- a/interface/vmcs_host/CMakeLists.txt
+++ b/interface/vmcs_host/CMakeLists.txt
@@ -2,7 +2,7 @@
# vc_vchi_gencmd.c has a type-punning problem in vc_gencmd_read_response
add_definitions(-fno-strict-aliasing)
-diff --git a/interface/vmcs_host/linux/vcfiled/CMakeLists.txt b/interface/vmcs_host/linux/vcfiled/CMakeLists.txt
-index aed0e83..d834b3f 100644
---- a/interface/vmcs_host/linux/vcfiled/CMakeLists.txt
-+++ b/interface/vmcs_host/linux/vcfiled/CMakeLists.txt
-@@ -1,5 +1,5 @@
-
--add_definitions(-Werror)
-+add_definitions()
-
- # vcfiled - serves files to videocore. used for media handlers from
- # OpenMAX/IL and loading VLLs.
--
-2.19.0
+2.23.0
config BR2_PACKAGE_PROVIDES_LIBOPENMAX
default "rpi-userland"
-config BR2_PACKAGE_RPI_USERLAND_START_VCFILED
- bool "Start vcfiled"
- depends on BR2_INIT_SYSV || BR2_INIT_BUSYBOX
- help
- vcfiled is a daemon serving files to VideoCore from the host
- file system.
-
config BR2_PACKAGE_RPI_USERLAND_HELLO
bool "hello_pi examples"
help
+++ /dev/null
-#!/bin/sh
-
-NAME=vcfiled
-DESC="VideoCore file server daemon $NAME"
-DAEMON="/usr/sbin/$NAME"
-DAEMON_ARGS=""
-CFGFILE="/etc/default/$NAME"
-PIDFILE="/var/run/$NAME.pid"
-
-# Read configuration variable file if it is present
-[ -r "$CFGFILE" ] && . "$CFGFILE"
-
-start()
-{
- printf "Starting $DESC: "
- start-stop-daemon -S -q -p "$PIDFILE" -x "$DAEMON" -- $DAEMON_ARGS &&
- echo "done" || echo "failed"
-}
-
-stop()
-{
- printf "Stopping $DESC: "
- if start-stop-daemon -K -q -R TERM/30/KILL/5 -p "$PIDFILE" -n "$NAME"; then
- # This daemon does not remove its PID file when it exits.
- rm -f "$PIDFILE"
- echo "done"
- else
- echo "failed"
- fi
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart|reload)
- stop
- start
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|reload}" >&2
- exit 1
- ;;
-esac
# Locally computed
-sha256 9424ffa45ef888fb61483c63fd66532c1c648e071fea72c93762efbb3c2a8669 rpi-userland-e5803f2c986cbf8c919c60278b3231dcdf4271a6.tar.gz
+sha256 d6231e9fa33c805cf7cbb559a0d6eb125605fc2ba862d9e5a3248778dd269859 rpi-userland-5070cb7fc150fc98f1ed64a7739c3356970d9f76.tar.gz
sha256 bee6f1249175683d8610651706e1aa7dffcbfd3f9c4c05bc1e5ab34f313c2db5 LICENCE
#
################################################################################
-RPI_USERLAND_VERSION = e5803f2c986cbf8c919c60278b3231dcdf4271a6
+RPI_USERLAND_VERSION = 5070cb7fc150fc98f1ed64a7739c3356970d9f76
RPI_USERLAND_SITE = $(call github,raspberrypi,userland,$(RPI_USERLAND_VERSION))
RPI_USERLAND_LICENSE = BSD-3-Clause
RPI_USERLAND_LICENSE_FILES = LICENCE
RPI_USERLAND_INSTALL_STAGING = YES
-RPI_USERLAND_CONF_OPTS = -DVMCS_INSTALL_PREFIX=/usr \
- -DCMAKE_C_FLAGS="$(TARGET_CFLAGS) \
- -DVCFILED_LOCKFILE=\\\"/var/run/vcfiled.pid\\\""
+RPI_USERLAND_CONF_OPTS = -DVMCS_INSTALL_PREFIX=/usr
RPI_USERLAND_PROVIDES = libegl libgles libopenmax libopenvg
-ifeq ($(BR2_PACKAGE_RPI_USERLAND_START_VCFILED),y)
-define RPI_USERLAND_INSTALL_INIT_SYSV
- $(INSTALL) -m 0755 -D package/rpi-userland/S94vcfiled \
- $(TARGET_DIR)/etc/init.d/S94vcfiled
-endef
-define RPI_USERLAND_INSTALL_INIT_SYSTEMD
- $(INSTALL) -D -m 644 package/rpi-userland/vcfiled.service \
- $(TARGET_DIR)/usr/lib/systemd/system/vcfiled.service
- mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
- ln -sf ../../../../usr/lib/systemd/system/vcfiled.service \
- $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/vcfiled.service
-endef
-endif
-
ifeq ($(BR2_PACKAGE_RPI_USERLAND_HELLO),y)
RPI_USERLAND_CONF_OPTS += -DALL_APPS=ON
endif # BR2_PACKAGE_RPI_USERLAND_HELLO
define RPI_USERLAND_POST_TARGET_CLEANUP
- rm -f $(TARGET_DIR)/etc/init.d/vcfiled
- rm -f $(TARGET_DIR)/usr/share/install/vcfiled
- rmdir --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share/install
rm -Rf $(TARGET_DIR)/usr/src
endef
RPI_USERLAND_POST_INSTALL_TARGET_HOOKS += RPI_USERLAND_POST_TARGET_CLEANUP
+++ /dev/null
-[Unit]
-Description=VideoCore file server daemon
-
-[Service]
-ExecStart=/usr/sbin/vcfiled --foreground
-Restart=always
-
-[Install]
-WantedBy=multi-user.target