package/nginx: add stream map option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 22 Jun 2020 19:31:11 +0000 (21:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 22 Jun 2020 20:44:24 +0000 (22:44 +0200)
stream map module has been added in version 1.11.3 with
https://github.com/nginx/nginx/commit/05db6ddfa1ca120c1c348cc750acded2a01b090a
and is enabled by default, add an option to be able to disable it

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 52711b1de30ff78bbdf015b3f536ef4f532d8f9d..64406664d3dacd7b383d5e484de25d5ac42ab93b 100644 (file)
@@ -346,6 +346,12 @@ config BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE
        help
          Enable ngx_stream_access_module
 
+config BR2_PACKAGE_NGINX_STREAM_MAP_MODULE
+       bool "ngx_stream_map_module"
+       default y
+       help
+         Enable ngx_stream_map_module
+
 config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE
        bool "ngx_stream_upstream_hash_module"
        default y
index 81708fd32f05eb7496e466b3cfe7a5b8f4952285..1ff59e7f971f83034964b3ce171de1fe78a9e679 100644 (file)
@@ -232,6 +232,7 @@ endif
 NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE),,--without-stream_limit_conn_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE),,--without-stream_access_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_MAP_MODULE),,--without-stream_map_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE),,--without-stream_upstream_hash_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_LEAST_CONN_MODULE),,--without-stream_upstream_least_conn_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_ZONE_MODULE),,--without-stream_upstream_zone_module)