package/lcdproc: remove freetype installation prefixes
authorRomain Naour <romain.naour@gmail.com>
Sat, 3 Jun 2017 16:36:26 +0000 (18:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 3 Jun 2017 16:55:53 +0000 (18:55 +0200)
Since [1] (freetype 2.8), freetype-config is now a wrapper of
pkg-config. So we don't need  to pass the freetype installation
prefixes on the configure command line anymore.

Setting freetype prefixes on the command line append the result
returned by pkg-config and the one provided on the command line.

FT2_CFLAGS='-I[...]/sysroot/usr/[...]/sysroot/usr/include/freetype2 -I[...]/usr/include'

This revert commit 3bdbe9abb90de0262832d5d545f239fa41fb0e91.

Fixes:
http://autobuild.buildroot.net/results/9c3/9c3f77e18ae244a2abb9ea70b6adebe215f143a6

[1] http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=1c513fbb8872bfac5631964963b6a751169a1ce6

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lcdproc/lcdproc.mk

index bd37b7ab81bee337f17f67b711e289302fed07e0..d86eb33f45cbbac3eff3c1d846e1cd5b5f6dd228 100644 (file)
@@ -10,9 +10,7 @@ LCDPROC_LICENSE = GPL-2.0+
 LCDPROC_LICENSE_FILES = COPYING
 LCDPROC_MAKE = $(MAKE1)
 
-LCDPROC_CONF_OPTS = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS) \
-       --with-ft-prefix="$(STAGING_DIR)/usr" \
-       --with-ft-exec-prefix="$(STAGING_DIR)/usr"
+LCDPROC_CONF_OPTS = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS)
 
 ifeq ($(BR2_PACKAGE_LCDPROC_MENUS),y)
 LCDPROC_CONF_OPTS += --enable-lcdproc-menus