mysql: fix debugging options
authorMarcelo Gutierrez <kuyurix@gmail.com>
Wed, 12 Feb 2014 22:39:34 +0000 (22:39 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Mar 2014 22:32:16 +0000 (23:32 +0100)
The usual --{en,dis}able-debug passed by the infrastructure are not
recognised by mysql's ./configure, as it uses unusual options.

Also, debugging is only meaningful to the server, not the client.

Signed-off-by: Marcelo Gutierrez (UTN/FRH) <kuyurix@gmail.com>
[yann.morin.1998@free.fr: actually add the options, move in server if-block]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mysql/mysql.mk

index 27afc9f86418566bfa0c50dbfd2d4ea80f965eb6..95b30b7011a132e93b7b1a9c39c1f0b1e50fe585 100644 (file)
@@ -30,8 +30,7 @@ MYSQL_CONF_OPT = \
        --without-libedit \
        --without-readline \
        --with-low-memory \
-       --enable-thread-safe-client \
-       $(ENABLE_DEBUG)
+       --enable-thread-safe-client
 
 ifeq ($(BR2_PACKAGE_MYSQL_SERVER),y)
 MYSQL_DEPENDENCIES += host-mysql host-bison
@@ -57,6 +56,14 @@ MYSQL_CONF_OPT += \
        --without-plugin-innodb_plugin \
        --without-plugin-ndbcluster
 
+# Debugging is only available for the server, so no need for
+# this if-block outside of the server if-block
+ifeq ($(BR2_ENABLE_DEBUG),y)
+MYSQL_CONF_OPT += --with-debug=full
+else
+MYSQL_CONF_OPT += --without-debug
+endif
+
 define HOST_MYSQL_BUILD_CMDS
        $(MAKE) -C $(@D)/include my_config.h
        $(MAKE) -C $(@D)/mysys libmysys.a