Get rid of now unused HOST_ARCH computation code
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Apr 2010 21:19:24 +0000 (23:19 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 11 Apr 2010 19:10:34 +0000 (21:10 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in

index 8f1a29db2ded0edb9155c2a52b5b2a11d4a2a8f6..43ff2ddad70360c650938aade44bfa1bab496e59 100644 (file)
@@ -174,20 +174,6 @@ HOST_PATH=$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(PATH)
 HOSTCC_VERSION:=$(shell $(HOSTCC) --version | \
        sed -n 's/^.* \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\)[ ]*.*$$/\1\2\3/p')
 
-HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-       -e 's/sparc.*/sparc/' \
-       -e 's/arm.*/arm/g' \
-       -e 's/m68k.*/m68k/' \
-       -e 's/ppc/powerpc/g' \
-       -e 's/v850.*/v850/g' \
-       -e 's/sh[234]/sh/' \
-       -e 's/mips-.*/mips/' \
-       -e 's/mipsel-.*/mipsel/' \
-       -e 's/cris.*/cris/' \
-       -e 's/i[3-9]86/i386/' \
-       -e 's/xtensa.*/xtensa/' \
-       )
-
 TARGET_CONFIGURE_OPTS=PATH=$(TARGET_PATH) \
                AR="$(TARGET_AR)" \
                AS="$(TARGET_AS)" \