libethumb: Fix automagic dependencies on libedbus and libexif
authorMarkos Chandras <markos.chandras@imgtec.com>
Sun, 11 Mar 2012 13:15:00 +0000 (14:15 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 13 Mar 2012 12:12:02 +0000 (13:12 +0100)
libethumb will determine during configuration phase whether to build the
optional libexif and libedbus modules. It will enable this modules if
libedbus or libexif are present on the target system. Therefore, we need
to add these packages as optional dependencies to libethumb.

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libethumb/libethumb.mk

index 16b2ba9553fb8dfa2afe142d2a74af17c1e8234f..617de0d7908790bf453922449043a1487a2a06cc 100644 (file)
@@ -13,4 +13,12 @@ LIBETHUMB_DEPENDENCIES = libeina libevas libecore libedje host-libedje
 
 LIBETHUMB_CONF_OPT = --with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc
 
+ifeq ($(BR2_PACKAGE_LIBEXIF),y)
+LIBETHUMB_DEPENDENCIES += libexif
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS),y)
+LIBETHUMB_DEPENDENCIES += libedbus
+endif
+
 $(eval $(call AUTOTARGETS))