- add option to pass to tar for unpacking the source.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 10 Dec 2005 14:59:02 +0000 (14:59 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 10 Dec 2005 14:59:02 +0000 (14:59 -0000)
  Set it to exclude .svn per default (please default to "" if inappropriate)

Config.in
Makefile

index 8714bc633c8d4ece7e3f5eb607cfd5532a9bd883..f62f9c9733c138c1f9c29044042aaf5d4b270d0c 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -125,6 +125,10 @@ config BR2_TAR_VERBOSITY
        bool "Tar verbose"
        default n
 
+config BR2_TAR_OPTIONS
+       string "Tar options"
+       default "--exclude='.svn'"
+
 config BR2_DL_DIR
        string "Download dir"
        default "$(BASE_DIR)/dl"
index 5d8f7259924d5c8d18366199035c411d765f5734..629129603bb3480b47675619d3462586ea18c421 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -36,9 +36,11 @@ ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
 endif
 
 ifeq ($(BR2_TAR_VERBOSITY),y)
-TAR_OPTIONS=-xvf
+TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xvf
+#"
 else
-TAR_OPTIONS=-xf
+TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
+#"
 endif
 
 ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)