perl: removes useless files in target tree
authorFrancois Perrad <fperrad@gmail.com>
Tue, 3 Jun 2014 18:46:58 +0000 (20:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Jun 2014 15:23:10 +0000 (17:23 +0200)
$(TARGET_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE contains include files.
*.bs & .packlist files come with perl or perl/cpan packages.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 08696f757c0d4d901b1bf9677835b40d3297447d..55010687bfad2f179690c42d2e46af2f1e4a01cf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -554,6 +554,9 @@ ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY)$(BR2_PACKAGE_PYTHON3_PYC_ONLY),y)
        find $(TARGET_DIR)/usr/lib/ -name '*.py' -print0 | xargs -0 rm -f
 endif
        rm -rf $(TARGET_DIR)/usr/lib/luarocks
+       rm -rf $(TARGET_DIR)/usr/lib/perl5/$(PERL_VERSION)/$(PERL_ARCHNAME)/CORE
+       find $(TARGET_DIR)/usr/lib/perl5/ -name '*.bs' -print0 | xargs -0 rm -f
+       find $(TARGET_DIR)/usr/lib/perl5/ -name '.packlist' -print0 | xargs -0 rm -f
        $(STRIP_FIND_CMD) | xargs $(STRIPCMD) 2>/dev/null || true
        if test -d $(TARGET_DIR)/lib/modules; then \
                find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \