orc: new package
authorSven Neumann <s.neumann@raumfeld.com>
Thu, 14 Jul 2011 07:32:39 +0000 (09:32 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Jul 2011 21:44:01 +0000 (23:44 +0200)
Orc - the Oil Runtime Compiler - is the successor of liboil.
There's a runtime library that is installed in staging and target
and there's a host version that can be built if orcc, the ORC
compiler is needed at build time.

[Peter: minor tweaks]
Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/orc/Config.in [new file with mode: 0644]
package/orc/orc.mk [new file with mode: 0644]

index b9bd529924b5747f48166bb9200d9f6e0309ee5d..28e55700cbf163143ce4679f27af1c7c1524f9c7 100644 (file)
@@ -346,6 +346,7 @@ source "package/libglib2/Config.in"
 source "package/libnspr/Config.in"
 source "package/liboil/Config.in"
 source "package/libsigc/Config.in"
+source "package/orc/Config.in"
 source "package/startup-notification/Config.in"
 endmenu
 
diff --git a/package/orc/Config.in b/package/orc/Config.in
new file mode 100644 (file)
index 0000000..1de0f23
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_ORC
+       bool "orc"
+       help
+         Orc is a library and set of tools for compiling and executing
+         very simple programs that operate on arrays of data.
+
+         http://code.entropywave.com/projects/orc/
diff --git a/package/orc/orc.mk b/package/orc/orc.mk
new file mode 100644 (file)
index 0000000..f89d5cf
--- /dev/null
@@ -0,0 +1,10 @@
+#############################################################
+#
+# orc
+#
+#############################################################
+ORC_VERSION = 0.4.14
+ORC_SITE = http://code.entropywave.com/download/orc/
+ORC_INSTALL_STAGING = YES
+
+$(eval $(call AUTOTARGETS,package,orc))