package/openssl: depend on the virtual cryptodev package
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 3 Sep 2016 22:58:41 +0000 (00:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Sep 2016 13:39:27 +0000 (15:39 +0200)
Instead of depending on each provider of cryptodev, make openssl depend
on the virtual package.

This is easy because in both cases the openssl build systems needs the
same configuration options.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openssl/openssl.mk

index b926fe30af8f32f9890bb279b4f50c2bef881157..efe2b49ad8f679875fc27934ce22f9ded62f5e51 100644 (file)
@@ -28,14 +28,9 @@ ifeq ($(BR2_USE_MMU),)
 OPENSSL_CFLAGS += -DHAVE_FORK=0
 endif
 
-ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
+ifeq ($(BR2_PACKAGE_HAS_CRYPTODEV),y)
 OPENSSL_CFLAGS += -DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS
-OPENSSL_DEPENDENCIES += cryptodev-linux
-endif
-
-ifeq ($(BR2_PACKAGE_OCF_LINUX),y)
-OPENSSL_CFLAGS += -DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS
-OPENSSL_DEPENDENCIES += ocf-linux
+OPENSSL_DEPENDENCIES += cryptodev
 endif
 
 # Some architectures are optimized in OpenSSL