package/weston: libxkbcommon is optional
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 1 Jun 2014 21:43:46 +0000 (23:43 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Jun 2014 11:10:48 +0000 (13:10 +0200)
It is possible to build weston without libxkbcommon, for example
if using an input method that is not an hardware keyboard (e.g. a
virtual keyboard, or none at all.)

Make it optional.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/weston/Config.in
package/weston/weston.mk

index aaef405e0fe489904c082c46d25337e870527c31..96ebdf1686fc9c27eeaca658c49d9474dc1b6eb5 100644 (file)
@@ -5,7 +5,6 @@ comment "weston needs udev and a toolchain w/ threads, headers >= 3.0"
 config BR2_PACKAGE_WESTON
        bool "weston"
        select BR2_PACKAGE_WAYLAND
-       select BR2_PACKAGE_LIBXKBCOMMON
        select BR2_PACKAGE_CAIRO
        select BR2_PACKAGE_CAIRO_PNG
        select BR2_PACKAGE_LIBPNG
@@ -29,6 +28,16 @@ config BR2_PACKAGE_WESTON
 
 if BR2_PACKAGE_WESTON
 
+config BR2_PACKAGE_WESTON_HW_KBD
+       bool "enable keyboard support"
+       default y
+       select BR2_PACKAGE_LIBXKBCOMMON
+       help
+         Say 'y' here if you plan on using a keyboard.
+
+         Only say 'n' if you're going to use a virtual keyboard or any other
+         input method.
+
 # Helper to make sure at least one compositor is selected.
 config BR2_PACKAGE_WESTON_HAS_COMPOSITOR
        bool
index 8188ae6ce8a6f6f7629b06afc9d9753aa0061a19..ea632037638290af9228219eaff6e108a460f75a 100644 (file)
@@ -10,7 +10,7 @@ WESTON_SOURCE = weston-$(WESTON_VERSION).tar.xz
 WESTON_LICENSE = MIT
 WESTON_LICENSE_FILES = COPYING
 
-WESTON_DEPENDENCIES = host-pkgconf wayland libxkbcommon pixman libpng \
+WESTON_DEPENDENCIES = host-pkgconf wayland pixman libpng \
        jpeg mtdev udev cairo
 
 WESTON_CONF_OPT = \
@@ -25,6 +25,13 @@ WESTON_CONF_OPT = \
        --disable-weston-launch \
        --disable-colord
 
+ifeq ($(BR2_PACKAGE_WESTON_HW_KBD),y)
+WESTON_DEPENDENCIES += libxkbcommon
+WESTON_CONF_OPT += --enable-xkbcommon
+else
+WESTON_CONF_OPT += --disable-xkbcommon
+endif
+
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 WESTON_DEPENDENCIES += libunwind
 else