package/llvm: delete LLVMHello.so from /usr/lib
authorValentin Korenblit <valentin.korenblit@smile.fr>
Wed, 2 May 2018 09:05:35 +0000 (11:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 2 May 2018 09:33:22 +0000 (11:33 +0200)
LLVMHello.so contains the Hello World example of an
LLVM pass. It is not needed on the target.

Signed-off-by: Valentin Korenblit <valentin.korenblit@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/llvm/llvm.mk

index a25495fbd7de251526c1e826a76788098a477256..978f176f2839421f97a4f5c488f1de09a8ef0650 100644 (file)
@@ -267,9 +267,9 @@ endef
 HOST_LLVM_POST_INSTALL_HOOKS = HOST_LLVM_COPY_LLVM_CONFIG_TO_STAGING_DIR
 
 # By default llvm-tblgen is built and installed on the target but it is
-# not necessary.
+# not necessary. Also erase LLVMHello.so from /usr/lib
 define LLVM_DELETE_LLVM_TBLGEN_TARGET
-       rm -f $(TARGET_DIR)/usr/bin/llvm-tblgen
+       rm -f $(TARGET_DIR)/usr/bin/llvm-tblgen $(TARGET_DIR)/usr/lib/LLVMHello.so
 endef
 LLVM_POST_INSTALL_TARGET_HOOKS = LLVM_DELETE_LLVM_TBLGEN_TARGET