arch: drop BR2_GCC_TARGET_CPU_REVISION option
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 23 Sep 2018 20:38:49 +0000 (22:38 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Oct 2018 12:52:32 +0000 (14:52 +0200)
In commit 325bb37942f8d3826dab9dc6e88b25234e67a2cf, support for the
Blackfin architecture was removed. This was our only use of
BR2_GCC_TARGET_CPU_REVISION, and since this config option somewhat
complicates the calculation of the --with-cpu/-mcpu option values,
let's drop it.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
arch/Config.in
arch/arch.mk
package/gcc/gcc.mk
toolchain/toolchain-external/pkg-toolchain-external.mk

index 8bd57fe1ccc39dffa0e05892a2efd2cad2b2b047..f50760a0cff90c914bc4593ab82ea2a381742dd0 100644 (file)
@@ -317,9 +317,6 @@ config BR2_GCC_TARGET_FP32_MODE
 config BR2_GCC_TARGET_CPU
        string
 
-config BR2_GCC_TARGET_CPU_REVISION
-       string
-
 # The value of this option will be passed as --with-fpu=<value> when
 # building gcc (internal backend) or -mfpu=<value> in the toolchain
 # wrapper (external toolchain)
index 6c1527090353ffade84c52270125fa6c7f410e3c..289c5a11257fa8d5b7375a2ad3b52b08bd787e4a 100644 (file)
@@ -14,7 +14,6 @@ GCC_TARGET_ABI := $(call qstrip,$(BR2_GCC_TARGET_ABI))
 GCC_TARGET_NAN := $(call qstrip,$(BR2_GCC_TARGET_NAN))
 GCC_TARGET_FP32_MODE := $(call qstrip,$(BR2_GCC_TARGET_FP32_MODE))
 GCC_TARGET_CPU := $(call qstrip,$(BR2_GCC_TARGET_CPU))
-GCC_TARGET_CPU_REVISION := $(call qstrip,$(BR2_GCC_TARGET_CPU_REVISION))
 GCC_TARGET_FPU := $(call qstrip,$(BR2_GCC_TARGET_FPU))
 GCC_TARGET_FLOAT_ABI := $(call qstrip,$(BR2_GCC_TARGET_FLOAT_ABI))
 GCC_TARGET_MODE := $(call qstrip,$(BR2_GCC_TARGET_MODE))
index 5f6d53f106239392051a4dc407b2feb8e01b038f..9e9069ce0e276cf3eaf1a9cc70b7ea53c3401452 100644 (file)
@@ -215,12 +215,8 @@ ifneq ($(GCC_TARGET_FP32_MODE),)
 HOST_GCC_COMMON_CONF_OPTS += --with-fp-32="$(GCC_TARGET_FP32_MODE)"
 endif
 ifneq ($(GCC_TARGET_CPU),)
-ifneq ($(GCC_TARGET_CPU_REVISION),)
-HOST_GCC_COMMON_CONF_OPTS += --with-cpu=$(GCC_TARGET_CPU)-$(GCC_TARGET_CPU_REVISION)
-else
 HOST_GCC_COMMON_CONF_OPTS += --with-cpu=$(GCC_TARGET_CPU)
 endif
-endif
 
 ifneq ($(GCC_TARGET_FPU),)
 HOST_GCC_COMMON_CONF_OPTS += --with-fpu=$(GCC_TARGET_FPU)
index 08e61af00bca8005c3e72e36bb224b6c916e0905..241a39a5ee61e027dd6d6fd0e1e1edaf718b7510 100644 (file)
@@ -151,11 +151,7 @@ TOOLCHAIN_EXTERNAL_LIBS += $(call qstrip,$(BR2_TOOLCHAIN_EXTRA_EXTERNAL_LIBS))
 # Definition of the CFLAGS to use with the external toolchain, as well as the
 # common toolchain wrapper build arguments
 #
-ifeq ($(GCC_TARGET_CPU_REVISION),)
 CC_TARGET_CPU_ := $(GCC_TARGET_CPU)
-else
-CC_TARGET_CPU_ := $(GCC_TARGET_CPU)-$(GCC_TARGET_CPU_REVISION)
-endif
 CC_TARGET_ARCH_ := $(GCC_TARGET_ARCH)
 CC_TARGET_ABI_ := $(GCC_TARGET_ABI)
 CC_TARGET_NAN_ := $(GCC_TARGET_NAN)