gst-fsl-plugins: bump version to 4.0.2
authorGary Bisson <gary.bisson@boundarydevices.com>
Tue, 26 May 2015 08:19:33 +0000 (10:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Jul 2015 10:45:48 +0000 (12:45 +0200)
This patch is based on the Yocto equivalent:
https://github.com/Freescale/meta-fsl-arm/commit/730b7ca5d2f13083f4e44636308a2f55a8d346f2

This package has been tested using the following commands:
 # gst-launch-0.10 playbin uri=file:///root/tears_of_steel_1080p.webm
 # gst-launch-0.10  filesrc location=/root/tears_of_steel_1080p.webm ! \
   matroskademux ! vpudec ! autovideosink
 # gst-launch-0.10  filesrc location=/root/tears_of_steel_1080p.webm ! \
   matroskademux ! vpudec ! mfw_isink
 # gst-launch-0.10 imxv4l2src ! autovideosink

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer/gst-fsl-plugins/0002-Fix-bashism-in-configure-script.patch
package/gstreamer/gst-fsl-plugins/gst-fsl-plugins.mk

index 35617cd419589457d2eaef38fe252bd3e64798dd..471c48364df489a900822259e63617941f34e2f0 100644 (file)
@@ -25,7 +25,7 @@ index 5968eb6..1a31a06 100755
  fi
  AC_SUBST(VPU_LIBS)
  
-@@ -176,15 +176,15 @@ AC_SUBST(RT_CFLAGS)
+@@ -176,14 +176,14 @@ AC_SUBST(RT_CFLAGS)
  AC_SUBST(RT_LIBS)
  
  FSL_MM_CORE_CFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec 2>/dev/null`
@@ -40,10 +40,8 @@ index 5968eb6..1a31a06 100755
  FSL_MM_CORE_LIBS=`$PKG_CONFIG --libs libfslaudiocodec 2>/dev/null`
 -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslvideocodec 2>/dev/null`
 -FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslparser 2>/dev/null`
--FSL_MM_CORE_LIBS+=`$PKG_CONFIG --libs libfslvpuwrap 2>/dev/null`
 +FSL_MM_CORE_LIBS="$FSL_MM_CORE_LIBS `$PKG_CONFIG --libs libfslvideocodec 2>/dev/null`"
 +FSL_MM_CORE_LIBS="$FSL_MM_CORE_LIBS `$PKG_CONFIG --libs libfslparser 2>/dev/null`"
-+FSL_MM_CORE_LIBS="$FSL_MM_CORE_LIBS `$PKG_CONFIG --libs libfslvpuwrap 2>/dev/null`"
  AC_SUBST(FSL_MM_CORE_LIBS)
  
  EXTRAPLATFORMCFLAGS="-DARM -D_GNUC_"
index 8d8b8b48205c1951ed9a35a94b1da675e68d434b..a7dea0f769a7ca61599a7b4e2b81061d6c269208 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GST_FSL_PLUGINS_VERSION = 3.0.11
+GST_FSL_PLUGINS_VERSION = 4.0.2
 GST_FSL_PLUGINS_SITE = $(FREESCALE_IMX_SITE)
 
 # Most is LGPLv2+, but some sources are copied from upstream and are