package/apparmor: fixing installation os detection
authorAngelo Compagnucci <angelo@amarulasolutions.com>
Fri, 24 Apr 2020 10:47:23 +0000 (12:47 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 24 Apr 2020 11:06:03 +0000 (13:06 +0200)
Actually the install target of some tools like the parser tries to do
an os detection to understand what install and where.
Incidentally, when the install is invoked on SuSE, this will trig a bug
in parallel install which manifests as "target/lib/apparmor: File exists"
error. For this problem, a patch is already sent upstream.

For buildroot instead, the os detection is useless so we disable it
and use a generic install method.

Fixes:
http://autobuild.buildroot.net/results/b18c6a9ce67065dcb7968c6f473b3b403d2925d2

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/apparmor/apparmor.mk

index 311a79799f386d30b230b263d7f182f36f803508..9180fcd8030bb608ebde6ca5273514e30385ee6a 100644 (file)
@@ -15,7 +15,7 @@ APPARMOR_LICENSE_FILES = LICENSE parser/COPYING.GPL
 APPARMOR_DEPENDENCIES = libapparmor
 
 APPARMOR_TOOLS = parser
-APPARMOR_MAKE_OPTS = USE_SYSTEM=1
+APPARMOR_MAKE_OPTS = USE_SYSTEM=1 DISTRO=unknown
 
 ifeq ($(BR2_PACKAGE_APPARMOR_BINUTILS),y)
 APPARMOR_TOOLS += binutils