Cleanup the VCS commands configuration
authorMaxime Petazzoni <maxime.petazzoni@bulix.org>
Thu, 2 Sep 2010 10:09:45 +0000 (12:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Sep 2010 06:17:57 +0000 (08:17 +0200)
It's not really necessary to differenciate the commands for checking out
or updating a repository. Only the path to the binary and eventual
top-level flags are useful to configure.

Signed-off-by: Maxime Petazzoni <maxime.petazzoni@bulix.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in
Makefile

index da3619a2a7d0083b7210525d051e6c4366711d15..0f8ddf4fab3d08deebeee2ecd63cffc02866bd11 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -21,25 +21,17 @@ config BR2_WGET
        string "Wget command"
        default "wget --passive-ftp -nd"
 
-config BR2_SVN_CO
-       string "Subversion (svn) command to download source tree"
-       default "svn co"
+config BR2_SVN
+       string "Subversion (svn) command"
+       default "svn"
 
-config BR2_SVN_UP
-       string "Subversion (svn) command to update source tree"
-       default "svn up"
-
-config BR2_BZR_CO
-       string "Bazaar (bzr) command to download source tree"
-       default "bzr co"
-
-config BR2_BZR_UP
-       string "Bazaar (bzr) command to update source tree"
-       default "bzr up"
+config BR2_BZR
+       string "Bazaar (bzr) command"
+       default "bzr"
 
 config BR2_GIT
-       string "Git command to download source tree"
-       default "git clone"
+       string "Git command"
+       default "git"
 
 config BR2_ZCAT
        string "zcat command"
index 59a0e23034e34bf34b8c5422cd7bb1a9c3b8c787..77804030874bdc54599af4e0c874b58d5161f628 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -245,10 +245,8 @@ ARCH:=$(ARCH)_$(call qstrip,$(BR2_xtensa_core_name))
 endif
 
 WGET:=$(call qstrip,$(BR2_WGET)) $(QUIET)
-SVN_CO:=$(call qstrip,$(BR2_SVN_CO)) $(QUIET)
-SVN_UP:=$(call qstrip,$(BR2_SVN_UP)) $(QUIET)
-BZR_CO:=$(call qstrip,$(BR2_BZR_CO)) $(QUIET)
-BZR_UP:=$(call qstrip,$(BR2_BZR_UP)) $(QUIET)
+SVN:=$(call qstrip,$(BR2_SVN)) $(QUIET)
+BZR:=$(call qstrip,$(BR2_BZR)) $(QUIET)
 GIT:=$(call qstrip,$(BR2_GIT)) $(QUIET)
 ZCAT:=$(call qstrip,$(BR2_ZCAT))
 BZCAT:=$(call qstrip,$(BR2_BZCAT))