qt: fix alsa-lib dependency
authorLuca Ceresoli <luca@lucaceresoli.net>
Wed, 21 Jul 2010 21:20:59 +0000 (23:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jul 2010 20:52:50 +0000 (22:52 +0200)
If BR2_PACKAGE_QT_AUDIO_BACKEND=y, QtMultimedia requires the audio backend
to be already in staging in order to compile.
The backend is system-dependent, but since buildroot builds Linux systems
only, it is safe to assume that the it will always be ALSA.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/Config.in
package/qt/qt.mk

index b09d6429c7f013c74f411265998ca6274c237781..93a8ab1a86a9f7d3c762cc18282b4bcb323cc6d3 100644 (file)
@@ -311,8 +311,9 @@ config BR2_PACKAGE_QT_MULTIMEDIA
 config BR2_PACKAGE_QT_AUDIO_BACKEND
        bool "QtMultimedia Audio backend"
        depends on BR2_PACKAGE_QT_MULTIMEDIA
+       select BR2_PACKAGE_ALSA_LIB
        help
-         Build the platform audio backend into QtMultimedia if available
+         Build the ALSA audio backend into QtMultimedia
 
 config BR2_PACKAGE_QT_SVG
        bool "SVG Module"
index 864e79bb60a9812b1b5707ea709f05b0d11da96b..baf653991ddc74e575bfc7b9dbbbff1dc0de0662 100644 (file)
@@ -312,6 +312,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_QT_AUDIO_BACKEND),y)
 QT_CONFIGURE+= -audio-backend
+QT_DEP_LIBS+=alsa-lib
 else
 QT_CONFIGURE+= -no-audio-backend
 endif